Tutorial Excel 2010: Función SI anidada

La función SI nos permite evaluar una condición y ejecutar una acción dependiendo el resultado, ya sea verdadero o falso. Esto funciona muy bien cuando solo estamos comparando dos valores pero ¿Cómo podemos utilizar la función SI al tener más de dos posibles opciones? La respuesta es utilizar la función SI anidada.

Descarga el archivo utilizado en esta lección
Video tutorial de la función SI

La función SI anidada

Para utilizar correctamente la función SI anidada debemos utilizar una función SI como el tercer argumento de la función principal. Por ejemplo, para evaluar si una celda tiene alguna de las tres letras posibles (A, B, C) podemos utilizar la siguiente fórmula:

=SI(A1="A",100,SI(A1="B",80,60))

Si el valor de la celda A1 tiene la letra A obtendremos el valor 100. Si la celda A1 tiene la letra B, entonces obtendremos el valor 80, de lo contrario obtendremos el valor 60. En este ejemplo tenemos dos pruebas lógicas que nos ayudan a decidir correctamente sobre las tres opciones posibles. Observa cómo esta fórmula regresa el equivalente adecuado para cada letra de la columna A:

Tutorial Excel 2010: Función SI anidada

Si por el contrario, en lugar de tres opciones necesitamos considerar cuatro, solo debemos agregar otra función SI anidada a nuestra fórmula de la siguiente manera:

=SI(A1="A",100,SI(A1="B",80,SI(A1="C",60,40)))

Observa el resultado de esta fórmula, especialmente para los valores que tienen la letra “D”:

Función SI anidada en Excel 2010

Si tuviéramos una quinta opción, entonces remplazaría el último parámetro de la función SI que tiene el mayor nivel de anidación para insertar una nueva función SI de la siguiente manera:

=SI(A1="A",100,SI(A1="B",80,SI(A1="C",60,SI(A1="D",40,20))))

Como podrás ver, con cada función SI que agregamos a nuestra fórmula su complejidad irá en aumento y es muy común que muchos usuarios de Excel comiencen a tener problemas para escribir correctamente múltiples funciones SI anidadas.

Mi recomendación es no exceder el máximo de 4, o a lo mucho 5, funciones SI anidadas de manera que se pueda comprender fácilmente la intención de la fórmula y detectar cualquier error en su escritura. Pero si decides utilizar varias funciones SI anidadas debes recordar que nunca podrás exceder el máximo de 64 funciones anidadas que permite Excel 2010.

Material adicional

Si tienes una situación particular en Excel donde tienes una fórmula con muchas funciones SI anidadas y eso te está causando problemas para dar mantenimiento a la fórmula debes considerar seriamente utilizar la función BUSCARV. Consulta el siguiente artículo para conocer más sobre esta posibilidad: Utilizar BUSCARV en lugar de SI anidado.

23 pensamientos en “Tutorial Excel 2010: Función SI anidada

  1. carlos

    Excelente Moisés.
    Muy bueno. Saludos

    Responder
  2. carlos

    excelente la explicacion, y muy util en mi labor
    gracias.

    Responder
  3. Sergio

    Excelente apoyo, muchas gracias

    Responder
  4. igor cordoba

    excelente comentario y facil ejemplo de la funcion SI, ademas de los otros temas, gracias por tu ayuda. saludos

    Responder
  5. Julio Garcia

    Muy bien explicado, gracias

    Responder
  6. gerardo

    mis respetos tus consejos y tutorias son excelentes!!!!
    aunque cuando tengo errores en formulas vuelvo a acomenzar para ver el error y lo puedo corregir gracias!!

    Responder
  7. Mary

    Gracias por tus tutorias, muy completas y fáciles de entender,
    !Muchas gracias! :)

    Responder
  8. alicia

    Gracias por tus ejemplos faciles de entender……

    Responder
  9. ZULLY

    GRACIAS POR TENERTE LA PACIENCIA DE PONER EJEMPLOS

    TE FELICITO

    Responder
  10. Andrea Hernandez

    Buenas tardes, he revisado varios de tus tutoriales y me han sacado de muchos problemillas, sin embargo, no he logrado solucionar este, sucede que quiero insertar 3 condiciones, si el numero de la celda es menor a 9 que salga “NEGATIVO”, si es entre 9 y 11 “REPETIR” y si es mayor a 11 que salga “POSITIVO”. Inserte esta formula pero me sale error, no se si debo utilizar otra función o si debo corregir la formula.

    =SI(D411;”POSITIVO”;SI(D4>9<11"REPETIR")))

    Gracias, espero tu pronta respuesta y felicidades

    Responder
    1. Moisés Ortíz Autor

      Hola Andrea, utiliza la siguiente función SI anidada:
      =SI(D4>11;”POSITIVO”;SI(D4<9;”NEGATIVO”;”REPETIR”))

      Responder
  11. Gabriela

    muy bueno el video me salvó la vida … sigue así

    Responder
  12. àNGELS

    Muchas gracias por la ayuda y la claridad de las explicacions.
    Saludos

    Responder
  13. edinson andres

    gracias por tus ejemplos de Excel me salvaste

    Responder
  14. nafer

    muy buena explicación me sirvió de mucha ayuda para realizar un ejercicio

    Responder
  15. carlos villon davila

    gracias por la explicación de si anidado, muy buena explicación…..y sencilla.

    Responder
  16. GUSTAVO

    felicitaciones: excelente tu pagina y tus ayudas.
    Dios te bendiga.

    Responder
  17. milagros torres

    me sirvió de mucho … muy buena teoría de la función SI

    Responder
  18. alonso

    Es de los mejores tutoriales de nivel medio que he encontrado, claro y rápido en sus explicaciones……

    Responder
  19. MARIA ISABEL PARDO

    EXCELENTE EXPLICACIÓN DE LA FUNCIÓN SI. TE LO AGRADEZCO. ME HAN AYUDADO UN MONTÓN

    Responder
  20. Juan Carlos

    Magnifica explicación,lo haces tan sencillo…

    Responder
  21. Trinidad

    Muy bien hecho, me ha aclarado lo que necesitaba; sencillo y claro. Gracias

    Responder
  22. Viviana

    Muchas gracias tu método de explicación me pareció exelenteeee lo entendii todoo

    Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>