Tutorial Excel 2010: Función SI anidada

La función SI nos permite evaluar una condición y ejecutar una acción dependiendo el resultado, ya sea verdadero o falso. Esto funciona muy bien cuando solo estamos comparando dos valores pero ¿Cómo podemos utilizar la función SI al tener más de dos posibles opciones? La respuesta es utilizar la función SI anidada.

Descarga el archivo utilizado en esta lección
Video tutorial de la función SI

La función SI anidada

Para utilizar correctamente la función SI anidada debemos utilizar una función SI como el tercer argumento de la función principal. Por ejemplo, para evaluar si una celda tiene alguna de las tres letras posibles (A, B, C) podemos utilizar la siguiente fórmula:

=SI(A1="A",100,SI(A1="B",80,60))

Si el valor de la celda A1 tiene la letra A obtendremos el valor 100. Si la celda A1 tiene la letra B, entonces obtendremos el valor 80, de lo contrario obtendremos el valor 60. En este ejemplo tenemos dos pruebas lógicas que nos ayudan a decidir correctamente sobre las tres opciones posibles. Observa cómo esta fórmula regresa el equivalente adecuado para cada letra de la columna A:

Tutorial Excel 2010: Función SI anidada

Si por el contrario, en lugar de tres opciones necesitamos considerar cuatro, solo debemos agregar otra función SI anidada a nuestra fórmula de la siguiente manera:

=SI(A1="A",100,SI(A1="B",80,SI(A1="C",60,40)))

Observa el resultado de esta fórmula, especialmente para los valores que tienen la letra “D”:

Función SI anidada en Excel 2010

Si tuviéramos una quinta opción, entonces remplazaría el último parámetro de la función SI que tiene el mayor nivel de anidación para insertar una nueva función SI de la siguiente manera:

=SI(A1="A",100,SI(A1="B",80,SI(A1="C",60,SI(A1="D",40,20))))

Como podrás ver, con cada función SI que agregamos a nuestra fórmula su complejidad irá en aumento y es muy común que muchos usuarios de Excel comiencen a tener problemas para escribir correctamente múltiples funciones SI anidadas.

Mi recomendación es no exceder el máximo de 4, o a lo mucho 5, funciones SI anidadas de manera que se pueda comprender fácilmente la intención de la fórmula y detectar cualquier error en su escritura. Pero si decides utilizar varias funciones SI anidadas debes recordar que nunca podrás exceder el máximo de 64 funciones anidadas que permite Excel 2010.

Material adicional

Si tienes una situación particular en Excel donde tienes una fórmula con muchas funciones SI anidadas y eso te está causando problemas para dar mantenimiento a la fórmula debes considerar seriamente utilizar la función BUSCARV. Consulta el siguiente artículo para conocer más sobre esta posibilidad: Utilizar BUSCARV en lugar de SI anidado.

27 comentarios en “Tutorial Excel 2010: Función SI anidada

  1. carlos

    Excelente Moisés.
    Muy bueno. Saludos

  2. carlos

    excelente la explicacion, y muy util en mi labor
    gracias.

  3. Sergio

    Excelente apoyo, muchas gracias

  4. igor cordoba

    excelente comentario y facil ejemplo de la funcion SI, ademas de los otros temas, gracias por tu ayuda. saludos

  5. Julio Garcia

    Muy bien explicado, gracias

  6. gerardo

    mis respetos tus consejos y tutorias son excelentes!!!!
    aunque cuando tengo errores en formulas vuelvo a acomenzar para ver el error y lo puedo corregir gracias!!

  7. Mary

    Gracias por tus tutorias, muy completas y fáciles de entender,
    !Muchas gracias! :)

  8. alicia

    Gracias por tus ejemplos faciles de entender……

  9. ZULLY

    GRACIAS POR TENERTE LA PACIENCIA DE PONER EJEMPLOS

    TE FELICITO

  10. Andrea Hernandez

    Buenas tardes, he revisado varios de tus tutoriales y me han sacado de muchos problemillas, sin embargo, no he logrado solucionar este, sucede que quiero insertar 3 condiciones, si el numero de la celda es menor a 9 que salga “NEGATIVO”, si es entre 9 y 11 “REPETIR” y si es mayor a 11 que salga “POSITIVO”. Inserte esta formula pero me sale error, no se si debo utilizar otra función o si debo corregir la formula.

    =SI(D411;”POSITIVO”;SI(D4>9<11"REPETIR")))

    Gracias, espero tu pronta respuesta y felicidades

    1. Moisés Ortíz Autor

      Hola Andrea, utiliza la siguiente función SI anidada:
      =SI(D4>11;”POSITIVO”;SI(D4<9;”NEGATIVO”;”REPETIR”))

      1. Perla

        Hola Moises estoy viendo la formula del IF
        =SI(A1=”A”,100,SI(A1=”B”,80,60))
        Pero necesito que en ves de que sea igual a la letra A contenga la letra A o bien en este caso un numero de serie contenga el numero 231 la formula que uso es =IF(B6=”*231*”,TRUE)
        LA Columna B tiene numeros de serie 534231001, 258231005 ETC o bien pueden no contener 231 en medio yo necesito filtrar solo las series que contengan 231, pero no me sale hay forma de hacer esto?
        saludos…

        1. Moisés Ortíz Autor

          Hola Perla, la función SI (IF) no acepta el uso de caracteres comodín. Mi sugerencia es utilizar la función SI en combinación con la función ENCONTRAR, por ejemplo:
          =SI(ENCONTRAR(“231″, B6)>0, VERDADERO)

  11. Gabriela

    muy bueno el video me salvó la vida … sigue así

  12. àNGELS

    Muchas gracias por la ayuda y la claridad de las explicacions.
    Saludos

  13. edinson andres

    gracias por tus ejemplos de Excel me salvaste

  14. nafer

    muy buena explicación me sirvió de mucha ayuda para realizar un ejercicio

  15. carlos villon davila

    gracias por la explicación de si anidado, muy buena explicación…..y sencilla.

  16. GUSTAVO

    felicitaciones: excelente tu pagina y tus ayudas.
    Dios te bendiga.

  17. milagros torres

    me sirvió de mucho … muy buena teoría de la función SI

  18. alonso

    Es de los mejores tutoriales de nivel medio que he encontrado, claro y rápido en sus explicaciones……

  19. MARIA ISABEL PARDO

    EXCELENTE EXPLICACIÓN DE LA FUNCIÓN SI. TE LO AGRADEZCO. ME HAN AYUDADO UN MONTÓN

  20. Juan Carlos

    Magnifica explicación,lo haces tan sencillo…

  21. Trinidad

    Muy bien hecho, me ha aclarado lo que necesitaba; sencillo y claro. Gracias

  22. Viviana

    Muchas gracias tu método de explicación me pareció exelenteeee lo entendii todoo

  23. Adriana

    Excelentes sus tutoriales, muchas gracias!

  24. Julieth

    Me parece super estos tutoriales, son muy efectivos y sencillos de aplicar, Gracias Moises