La función SI en Excel

La función SI en Excel es parte del grupo de funciones Lógicas y nos permite evaluar una condición para determinar si es falsa o verdadera. La función SI es de gran ayuda para tomar decisiones en base al resultado obtenido en la prueba lógica.

Sintaxis de la función SI

Además de especificar la prueba lógica para la función SI también podemos especificar valores a devolver de acuerdo al resultado de la función.

Sintaxis de la función SI en Excel

  • Prueba_lógica (obligatorio): Expresión lógica que será evaluada para conocer si el resultado es VERDADERO o FALSO.
  • Valor_si_verdadero (opcional): El valor que se devolverá en caso de que el resultado de la Prueba_lógica sea VERDADERO.
  • Valor_si_falso (opcional): El valor que se devolverá si el resultado de la evaluación es FALSO.

La Prueba_lógica puede ser una expresión que utilice cualquier operador lógico o también puede ser una función de Excel que regrese como resultado VERDADERO o FALSO.

Los argumentos Valor_si_verdadero y Valor_si_falso pueden ser cadenas de texto, números, referencias a otra celda o inclusive otra función de Excel que se ejecutará de acuerdo al resultado de la Prueba_lógica.

Ejemplos de la función SI

Probaremos la función SI con el siguiente ejemplo. Tengo una lista de alumnos con sus calificaciones correspondientes en la columna B. Utilizando la función SI desplegaré un mensaje de APROBADO si la calificación del alumno es superior o igual a 60 y un mensaje de REPROBADO si la calificación es menor a 60. La función que utilizaré será la siguiente:

=SI(B2>=60,"APROBADO","REPROBADO")

Observa el resultado al aplicar esta fórmula en todas las celdas de la columna C.

Ejemplo de la función SI en Excel

Utilizar una función como prueba lógica

Es posible utilizar el resultado de otra función como la prueba lógica que necesita la función SI  siempre y cuando esa otra función regrese como resultado VERDADERO o FALSO. Un ejemplo de este tipo de función es la función ESNUMERO la cual evalúa el contenido de una celda y devuelve el valor VERDADERO en caso de que sea un valor numérico. En este ejemplo quiero desplegar  la leyenda “SI” en caso de que la celda de la columna A efectivamente tenga un número, de lo contrario se mostrará la leyenda “NO”.

=SI(ESNUMERO(A2), "SI", "NO")

Este es el resultado de aplicar la fórmula sobre los datos de la hoja:

Utilizar una función lógica como prueba dentro de la función SI

Utilizar una función como valor de regreso

Como último ejemplo mostraré que es posible utilizar una función para especificar el valor de regreso. Utilizando como base el ejemplo anterior, necesito que en caso de que la celda de la columna A contenga un valor numérico se le sume el valor que colocaré en la celda D1. La función que me ayudará a realizar esta operación es la siguiente:

=SI(ESNUMERO(A2), SUMA(A2, $D$1), "NO")

Como puedes observar, el segundo argumento es una función la cual se ejecutará en caso de que la prueba lógica sea verdadera. Observa el resultado de esta fórmula:

Utilizar una función como el valor de regreso para la función SI

Sólo en los casos donde la función SI era verdadera se realizó la suma. De la misma manera podríamos colocar una función para el tercer argumento en caso de que el resultado de la prueba lógica fuera falso.

Artículos relacionados
La función SI anidada

212 pensamientos en “La función SI en Excel

  1. YOPLY

    ESTA INFORMACION DE LA FUNCION “SI” REALMENTE ME AYUDO A ENTENDERLA GRACIAS :) =)

    Responder
  2. CECI VALLE

    HOLA ESTABA CHECANDO TUS APORTACIONES POR CIERTO EXCELENTES. TENGO UN PROBLEMIN INTRODUZCO ESTA FORMULA : =SI(C10=TIENE12CARACTERES,REDONDEAR(G19*0.1,2),SI(C10=TIENE13CARACTERES,0)); Y COMO QUE NO ESTA BIEN ME DEVUELVE #¿NOMBRE?.

    ME PUEDES AYUDAR.
    SALUDOS.

    Responder
    1. Moisés Ortíz Autor

      Hola Ceci, tu fórmula tiene el texto “TIENE12CARACTERES”. ¿Qué es eso? ¿Lo pusiste solo como ejemplo en este comentario o así tienes tu fórmula? De ser así, el problema es porque Excel no sabe qué significa ese texto.

      Responder
      1. CECI VALLE

        Mi condicion para que me de el resultado de la operacion es que en dicha celda se introduzcan 12 caracteres, si fueran 13 quiero resultado cero. Gracias.

        Responder
        1. Moisés Ortíz Autor

          Hola Ceci, no me queda claro si tu pregunta es ¿cómo contruir la condición? En ese caso esta sería la fórmula:
          =SI(LARGO(C10)=12,REDONDEAR(G19*0.1,2),SI(LARGO(C10)=13,0))

          Responder
          1. CECI VALLE

            MIL GRACIAS MOISES, ESTA FUE MI SOLUCION.

          2. MARIA ZAVALA

            Moises gracias me acabas de resolver un gran problema para chequear el largo de un campo de mas de 40 caracteres para transición de un sistema a otro….

      2. taizamorales

        me encanta la funcion si en este programa gracias por presentarlos :)

        Responder
  3. LUIS

    Hola Moisés, tengo un inconveniente con la función. En una celda F4 tengo 3 opciones a escoger ” v1, v2, v3″ cuando v1=5; v2=10; v3=15 resultados que estan en otra hoja “lista de costos” , use la siguiente formula: =SI(F4=”V1″;’LISTA COSTOS’!C12; SI(F4=”V2″;’LISTA COSTOS’!C13);SI(F4=”V3″;’LISTA COSTOS’!C14)) pero no funciona me dice que solo puedo poner 2 argumentos.Con 2 argumentos funciona sin problema: =SI(F4=”V1″;’LISTA COSTOS’!C12; SI(F4=”V2″;’LISTA COSTOS’!C13))

    Como puedo hacer para que pueda tener las 3 opciones?

    Responder
    1. Moisés Ortíz Autor

      Hola Luis, tienes mal ubicado un paréntesis y por esto obtienes ese mensaje.
      Después de !C13 no debe ir el paréntesis que cierra sino que debe ir hasta el final.

      Responder
      1. Guillermo VR

        Hola Moisés. Yo tengo otro problema muy similar. Donde K3 es 30, K4 es 15 ,y K5 es 40
        =SI(E12=K3;D12*F12*0.0036*60; SI(E12=K4;D12*F12*0.0072*60; SI(E12=K5;D12*F12*0.0024*60)))

        Me dice que no reconoce la fórmula.

        Responder
        1. Moisés Ortíz Autor

          Hola Guillermo, tu fórmula está bien escrita. La acabo de probar y funcionó correctamente. Claro que yo tuve que cambiar el punto y coma (;) por coma (,) porque mi Excel está configurado de esa manera, pero funcionó correctamente. ¿Cual es el mensaje exacto que arroja Excel?

          Responder
  4. REYNALDO

    hola Moises, es la primera vez que te escribo, podrias darme ejemplos de trabajos con fecha y años
    en las celdas, pues tengo una lista con fechas de vencimiento de contratos y debo resaltar con un mensaje los que ya acabaron su contrato en fechas pasadas.
    gracias y felicitaciones por tu gran trabajo eres el mejor!!

    Responder
  5. nayeli

    hola moises, espero me puedas ayudar no se que formula utilizar para hacer lo siguiente, tengo 5 columnas con formula ” si” solo en una de ellas de arroja un valor porcentual y en las restantes 4 el valor es falso es decir: columna a= 10 % b= falso c= falso d= falso e= falso, ahora necesito que el valor que fue cierto de las 5 columnas me lo arroje en una sola columna como he hago ayuda !!!! mil gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Nayeli, puedes solucionarlo con un si anidado:
      =SI(A1<>FALSO, A1, SI(B1<>FALSO,B1, SI(C1<>FALSO,C1, SI(D1<>FALSO,D1, SI(E1<>FALSO,E1)))))

      Responder
  6. leonardo

    me gustaria saber si exite una formula para que una cantidad se distribuya en varia fila
    ejemplo si tengo en A1 el numero 12 como hago que esa cantidad se divida por 3 pero que el resultado se
    distribuya en desde B1 hasta D1

    Responder
    1. Moisés Ortíz Autor

      Hola Leonardo, no existe una función de Excel que haga eso de manera automática. Necesitas indicar la fórmula adecuada en cada una de las celdas desde B1 hasta D1. La fórmula es muy simple solo coloca =A1/3 en cada celda y obtentrás el valor de A1 dividido por 3 en cada celda.

      Responder
  7. Miguel

    Hola Moisés,
    Tengo una duda.
    Cómo puedo hacer que compare 2 celdas al mismo tiempo? digamos un =IF(A4=”Asignación” & B4=”T420″,1,0)… cómo hago que eso funcione?

    Responder
  8. LUIS DIMAC

    Gracias, muy buen aporte, y también he tomado sentido en algunas cosas que desconocia, TE FELICITO !! …… un abrazo

    Responder
  9. Mauricio

    Hola Moisés, mi consulta es la siguiente: Para realizar proyectos tengo identificados 95 MUNICIPIOS y 7 REGIONES cada Municipio pertenece a una de las 7 Regiones, por ejemplo, los Municipios de La Paz, Palca, Mecapaca, Achocalla, El Alto, Viacha y Laja pertenecen a la región METROPOLITANA. Requiero que de forma automática al introducir el nombre de uno de los Municipios, aparezca la región a la que pertenece, no sé si la Función SI es aplicable a mi consulta, de no ser aplicable qué función debo utilizar. Gracia de antemano y felicidades por tu trabajo.

    Responder
  10. Renán Calvo

    Hola. Al utilizar la función “si”, en vez de utilizar la coma (,), hay que utilizar punto y coma (;).
    Después de reiterados ejercicios, lo comprobé. Utilizo Windows 8 y M. Office 2010.
    Gracias por su respuesta.

    Responder
    1. Moisés Ortíz Autor

      Hola Renán, el punto y coma se utiliza solo si tu equipo tiene configurado ese carácter como separador de listas (lo cual sucede con la configuración de España). Existen otros equipos en donde tenemos una configuración regional diferente y la coma es nuestro separador de listas y argumentos. Más información en el siguiente artículo:
      http://exceltotal.com/separador-de-argumentos-de-funciones-en-excel/

      Responder
      1. Renán Calvo

        Muy amable de su parte

        Responder
  11. Faby

    tengo dos columnas para comparar y quiero que si alguna de estas cambia me arroje la palabra falso y si son iguales que la celda quede en blanco, ya lo intente con la función si y no me sale.

    Responder
  12. inma

    Hola Moisés:

    Mil gracias por tu blog, está fenomenal. Quería pedirte ayuda. Tengo dos columnas con texto (la B y la D) y otra con números (la F). Quiero que si en la columna B pone lo que la celda B8 y en la columna D pone lo que en la celda D8, me de la suma de la columna F. Pongo esta fórmula =SI(Y((B8:B40;B8);(D8:D40;D8));(SUMA(F:F));0) pero me da error. ¿Me podrías ayudar?

    Muchas gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Inma, el error está con el primer argumento de la función SI, es decir, con la prueba lógica que estás indicando: Y((B8:B40,B8),(D8:D40,D8))
      Este uso de la función Y es incorrecto. Te recomiendo leer un poco más sobre su sintaxis y uso:
      http://exceltotal.com/la-funcion-y-en-excel/

      Responder
  13. Pamela

    Hola Moises, estoy usando el condicional SI, pero la condicion es que sea diferente, como lo puedo colocar ya que ese caracter no existe en el teclado

    Responder
    1. Moisés Ortíz Autor

      Hola Pamela, el operador “diferente” en Excel es: <>. Por ejemplo:
      =SI(1<>2,”Diferente”)

      Responder
  14. Analía

    Hola Moises, estoy haciendo una planilla para organizarme con ciertos trámites que ingresan a una reparticion publica. Los que entran como tramite “COMUN” tardan 23 dias, y los que entran como “URGENTE” tardan 5… como puedo hacer para que aclarando en la planilla que tipo de tramite es (COMUN/URGENTE), y teniendo tambien la cant de dias que pasaron desde la presentacion, me diga LISTO/EN TRAMITE. No se si me explico bien, esta es la formula que puse pero no me funciona: =SI(Y(O(G6=”COMUN”);Y(H6>=23));”LISTO”;”EN TRAMITE”). Desde ya muchas gracias! geniales tus trabajos

    Responder
    1. Moisés Ortíz Autor

      Hola Analía, creo que si entendí tu problema. La celda G6 tiene dos posibilidades COMUN/URGENTE y en la celda H6 tienes los días que pasaron desde la presentación. Si es así, entonces podrías utilizar la función SI anidada siguiente:
      =SI(G6=”COMUN”;SI(H6>=23;”LISTO”;”EN TRAMITE”);SI(“H6>=5;”LISTO”;”EN TRAMITE”))

      Responder
  15. yadira gonzalez

    hola Moise, antes que nada muy buenos aportes…. excelentes diria yo, mira estoy batallando con un ejercicio que tengo de excel con la funcion si, me dice la condicion que tengo que poner de acuerdo a una celda con fecha de ingreso debe de poner el tipo de categoria si es del año 2010 que ponga A si es 2011 B y si es 2013 C y tengo ese detalle….. el cual siempre me marca error…. me podrias ayudar gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Yadira, necesitas utilizar una función SI anidada:
      =SI(A1=2010,”A”,SI(A1=2011,”B”,SI(A1=2013,”C”)))

      Responder
  16. Jorge Perez

    Moises, buenas tardes :

    Tú blog me ha servido muchisimo para resolver inquietudes lo que afortunadamente me ha ayudado para resolver algunas inquietudes en mi empresa.Tengo una pregunta : en la columna A , de A2 a A6 tengo varios nombres, Gustavo, Karen, Sebastian, Alberto, Mario,Ivan, los cuales los debo relacionar con un cliente especifico en este caso BANCO y de la A7 a la A9, tengo a Jose, Fabian,Carlos; los cuales los debo relacionar con un cliente especifico en este caso PROCTER y bueno asi sucesivamente.Mi inquietud se basa en que si en una celda determinada coloco el nombre de uno de los de la lista BANCO, aparezca BANCO e igualmente para los de PROCTER y aparezca PROCTER.Que formula debo emplear.
    Anticipadamente mil gracias por la ayuda,dedicacion y tiempo que nos ofreces tan desintersadamente.
    Cordial saludo,

    Responder
      1. Jotge Perez

        Moises, muchisimas gacias por tú ayuda.Disculpa la demora de ofrecerte mis agradecimientos.

        Cordial saludo

        Responder
  17. Andres

    Muchisimas gracias! ahora si entendí.

    Responder
  18. Juana

    Hola! Tengo un listado para cálculo de comisiones con montos y en celdas de parámetros tengo un tope, porcentaje de comisión y monto fijo de comisión. Necesito calcular: para cada monto, si es menor o igual al tope se aplica el porcentaje de comisión y si es mayor al tope se asigna la comisión de monto fijo.
    Hice la fócula “=SI(I2<=Hoja3!B2;!I2*Hoja3!B3;Hoja3!B4)" donde los parámetros son:
    tope = Hoja3!B2
    porcentaje comisión = Hoja3!B3
    porcentaje monto fijo = Hoja3!B4

    Además aprovecho para consultarte cómo hago para que los parámetros queden fijos al arrastrar la fórmula hacia abajo.
    Muchas gracias!!

    Responder
    1. Moisés Ortíz Autor

      Hola Juana, no me queda claro el problema que tienes, a excepción de que observo un símbolo ! al inicio del segundo argumento el cual no debería estar presente.
      En cuanto a cómo “fijar” las referencias para que no se modifiquen al copiarlas, debes utilizar referencias absolutas:

      =SI(I2<=Hoja3!$B$2;I2*Hoja3!$B$3;Hoja3!$B$4)

      Responder
  19. Lizbeth

    hola sabes quisiera que me ayudes a utilizar la funcion si pero para varias condiciones, como lo haria? ayudame porfa!!

    Responder
  20. Erick

    Buenas Moises, necesito que excel mediante formato condicional me indique cuando faltan 60 días para que se cumpla una fecha “x”, adicionalmente que una vez identificados que faltan 60 días, los diez días siguientes me siga mostrando que faltan 59 días, 58 días, …… 50 días. La celda donde se muestra la cantidad de días que faltan, una vez que se identifique que faltan 60 días se debe poner de fondo rojo (señal de alerta).

    Muchas gracias

    Responder
  21. Luis

    Buenas Moises, ¿cómo puedo usar la función SI, cuando las pruebas lógicas contienen varias palabras, para distinguir unos de otras, pero al mismo tiempo coinciden en una que es la que quiero que tenga en cuenta? Me explico: quiero que me analice una serie de celdas en las que aparecen tipos de vehículos: furgoneta azul, furgoneta verde… Si aparece la palabra furgoneta, que me devuelva el valor 9; si no aparece (y aparece por ejemplo coche rojo), que me devuelva el valor 5…

    Responder
  22. albert

    Hola Moises. me servivieron de gran ayuda algunas funciones que he tomado como ejemplo para hacer mis trabajos…..¡gracias por las sugerencias que brindas!!

    Responder
  23. Araceli

    Moises buen dia.

    Tengo problemas para utilizar la formula SI.

    Requiero que en mi tabla de Excel salga si es 0.00 la leyenda de “pagada”
    Si es mayor a cero la leyenda de “por pagar”
    Si tengo un valor en negativo la leyenda de “saldo a favor”

    La formula que estoy utilizando pero no me queda es:
    =SI(AK6+AQ6>0,”POR PAGAR”,SI(AK6+AQ6=0,”PAGADA”,SI(AK6+AQ6<-1,"SALDO A FAVOR")))
    Agradezco tus comentarios.

    Responder
    1. Moisés Ortíz Autor

      Hola Araceli, tu fórmula está bien escrita ¿Cuál es el problema que tienes?
      Si acaso podría comentar que la última comparación debería ser AK6+AQ6<0 para incluir a todos los negativos y no AK6+AQ6<-1.

      Responder
  24. Andrés

    Hola Moises, tengo un problema con mi funcion logica me marca un error al momento de querer incluir más de 1 argumento. Mi funcion es la siguiente:
    =SI(F2=”PRI”,”PRD”,1,0)
    Pienso que quiza no estoy separando correctamente mis argumentos; como lo hago???. Saludos y gracias por la ayuda..y Felicitaciones por el BLOG

    Responder
    1. Moisés Ortíz Autor

      Hola Andrés, no me queda claro a lo que le estás llamando “argumento” pero sospecho que quisiste decir “condición”. Tu fórmula está incorrecta porque la función SI solo acepta 3 argumentos, el último 0 (cero) no debe estar presente.
      Si lo que quieres hacer es evaluar si una celda contiene el valor “PRI” o el valor “PRD”, entonces necesitas utilizar una función SI anidada:
      http://exceltotal.com/funcion-si-anidada/

      Responder
  25. Eduardo

    Estimado, estoy realizando una planilla excel en la cual requiero que si los estudiantes obtienen un puntaje igual o menor de 19, aparezca la palabra “No desarrollado), si el puntaje está entre 20 y 29 ” Parcialmente Desarrollado” y si el puntaje es igual o mayor a 30 aparezca la palabra “Desarrollado”.
    Cree la formula =SI(AU519;”Parcialmente Desarrollada”;SI(AU5>=30;”Desarrollada”)))
    la cual al aplicar me resulta para las primeras dos (No desarrollada y Parcialmente Desarrollada), sin embargo cuando el resultado es mayor o igual a 30 me aparece “Parcialmente Desarrollada” y no “Desarrollada” como lo solicité en la función.

    Le dejo mi inquietud, ojala pueda ayudarme.

    Saludos.

    Responder
    1. Moisés Ortíz Autor

      Hola Eduardo, intenta con la siguiente fórmula:
      =SI(AU5<=19; “No desarrollado”; SI(AU5<=29; “Parcialmente desarrollado”; “Desarrollado”))

      Responder
  26. jenny albarracin

    gracias por las facilitaciones del trabajo de la funcion si

    Responder
  27. MARIA

    Hola Moisés, tengo una columna en excel en la cual tengo la CURP, la cual consta de 18 caracteres, ¿qué fórmula puedo utilizar para que en caso de que sean menos o más me arroje el error?

    Mil gracias por tu apoyo

    Responder
    1. Moisés Ortíz Autor

      Hola María, utiliza la función LARGO que devuelve la longitud de una cadena de texto. La formula sería algo como:
      =SI(LARGO(A1)<>18,”ERROR”,A1)

      Responder
  28. Alejandra

    hola maises una pregunta tengo una tabla en don de hay una serie de pagares ejemplo 54667-1,54667-2 y asi hasta llegar a 10 me recomendaron la funcion de largo pero esa funcio me regresa la cantidad de bits y lo que quiero es que me de una lista solamnete de un solo numero como le digo a la formula que me deje solamente 5 caracteres que en realidad son y me me la muestre el numero origen que es el 54667
    me puedes ayudar.

    porfavor.

    Responder
  29. Salomon

    Hola Moisés:
    Deseo saber la formula para convertir de numero entero a letra, por ejemplo 14 debe decir Catorce, lo quiero para converir solamente de o a 20, que son los calificativos en mi pais.

    Responder
  30. Ayelen

    Hola Moises quisiera ponerle color a la celda verdadera y a la falsa otro color para diferenciarlos, como podria hacerlo, utilice una función si.

    Responder
  31. Isidro

    Hola Moisés,
    Estoy empezando con el tema excel y quiero hacer una formula para que por ejemplo si el valor de la columna H es PEPE me calcule un pocentaje 10% y si el valor es JUAN me calcule el 12%, si no hay ningún valor me calcule 15% sobre la columna K, como podria hacerlo, con la función SI es posible?
    Mil gracias de antemano.

    Responder
  32. victor

    Estimado moises..
    tengo una tabla de datos en 5 columnas por cantidades diferentes y q corresponden a suc de tiendas en las columnas a b c d y la e el total de todas las cantidades
    A B C D E
    10 5 8 2 = 25
    quisiera saber si me puedes dar la formula para que me arroje por % cual columna es la q cuenta con mayor cantidad
    es este caso seria la A
    si tengo encabezado seria el encabezado de la columna x ejemplo si le pongo suc norte.. eso quisera que me arroje..
    disculpa las molestias y espero que me ayudes con esta duda.

    agradezco tu pronta respuesta en el correo o por aqui
    muchas gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Víctor, para obtener el valor máximo utiliza la función MAX y para obtener el nombre de la columna que tiene el valor máximo puedes utilizar la combinación de funciones INDICE y COINCIDIR:
      =INDICE(A1:D1,1,COINCIDIR(MAX(A2:D2),A2:D2,0))

      Responder
  33. MONICA

    Moisés, está muy padre tu blog, he aprendido mucho leyéndolo. Fíjate que necesito anidar un VLOOKUP en un IF, pero la primera condicionante necesito que sea; si VLOOKUP da error, o sea #N/A… ¿cuál es el operador a utilizar?

    Gracias

    Responder
  34. Lizeth

    Moises, solo existe la función SI para evaluar condiciones?

    Responder
  35. MARIANA

    Hola Moisés, necesito usar esta función para 7 celdas que tienen S para si y N para no, para que si en alguna de esas hay S me ponga un “S” en la celda de análisis, hice la siguiente fórmula y me da error: =SI((AO2:AU2=S),”S”,”N”).

    Te agradezco infinitamente tu respuesta.

    Responder
    1. Moisés Ortíz Autor

      Hola Mariana, tu fórmula está correcta solo si sabes utilizar fórmulas matriciales. Si las fórmulas matriciales son un tema desconocido para ti entonces te recuerdo que no es válido comparar un rango con una constante y por lo tanto el problema es tu condición: AO2:AU2=S la cual debería ser solo AO2=”S” y posteriormente deberás copiar tu fórmula al resto de las celdas para obtener el resultado correcto de la función SI.

      Responder
  36. Ismael

    Quisiera saber como poner varias condiciones a la función si en Excel 2010
    Si me dan un ejemplo ya me arreglaría para realizar mi trabajo..
    Espero respuestas cuanto antes… muchas gracias

    Responder
  37. Emilio Pastor

    Hola Moises, tengo un problema, espero que me puedas ayudar, el caso es que tengo en una columna celdas con listas dentro con codigos postales que son letras(son de Reino Unido) y lo que me gustaria seria que en una columna de al lado se genere un 1 o un 0 cada vez que se marque uno de los codigos postales de la columna, de tal manera que se me generen 1 y 0 dependiendo de si he metido un codigo postal o no y asi saber cuantos codigos postales meto. Lo he intentado por todos los medios leyendo su blog pero no hay ningun ejemplo de eso, aplico esta formula =IF(F3=MainsData!A2:A125,1,0) siendo las casillas de la A2 a la A125 todos los codigos postales pero me sale siempre 0 porque compara si el codigo postal es igual a toda la columna lo que es falso. Bueno si me pudieses ayudar te lo agradeceria

    Un saludo, enhorabuena por el blog, muy interesante

    Responder
    1. Moisés Ortíz Autor

      Hola Emilio, estás haciendo un uso incorrecto de la función SI. Te recomiendo utilizar la función COINCIDIR la cual buscará cualquier coincidencia en la columna. Te dejo un vínculo hacia un artículo sobre esta función.
      http://exceltotal.com/la-funcion-coincidir-en-excel/

      Responder
  38. claudio

    Hola Moises, primero que nada agradecerte por tu tiempo.
    Tengo una hoja excel en donde registro todos los ingresos y egresos de materiales (eje. prensas, fusibles etc, etc, etc) estos estan por fecha, por ejemplo las prensas tuvieron egresos los dias 4,12,22 de marzo asi como los fusibles los dias 4,17,28 de marzo;(varias veces al dia) en la hoja 2 estoy tratando de confeccionar una planilla en donde mi base de datos es la hoja 1 Lo que necesito realizar es una formula donde tengo la fecha escrita y que me aparescan las cantidades de cada material egresadas por dia, estoy tratando con la funcion BuscarV, pero se que tengo que llamar 2 cosas , la fecha y el nombre del material para que me de el total egresado de ese dia solamente. Ademas de eso el material es entregado varias veces al dia y en esta planilla requiero que me de la suma total del dia en una sola celda.

    espero me puedas ayudar.

    Responder
  39. Enzo

    Buenas Moises:
    Tengo el siguiente inconveniente, quiero en la funcion si que mi prueba logica compare 2 condiciones y me parece que tengo q usar &. Cuando pongo la formula me devuelve otra cosa de lo que pido
    =SI(T7>O7&U7>P7;”BUENO”;(SI(T7<O7&U7<P7;"MALO";"REGULAR")))
    Esta es la formula que aplico, en el caso que me tiene que dar "REGULAR" me da "BUENO"… No encuentro el error.
    Gracias

    Responder
  40. rey100

    Hola Moisés,
    estoy intentando haceruna ficha de almacen y no consigo hacer que me sume esta formula:
    =SI(D7=0;F6-D7;SI(D7=0;F6+E7))))
    solo me resta, la parte final que tendria que sumar no me lo hace y no se porqué…
    Muchas gracias de antemano!!

    Responder
    1. Moisés Ortíz Autor

      Hola rey100, la suma F6+E7 jamás se realizará porque las dos función SI tienen la misma condición (D7=0).

      Responder
  41. cristobal

    gracias por tus aportes moises
    mi consulta es como hago para ponerle el significado(en texto) a un numero que formula utilizo ejemplo
    en A1 tengo el valor de 100 y quiero que en B1 diga cien
    ojala me puedas ayudar

    Responder
  42. Salvador

    Hola Moises,

    Tengo un problema, quisiera que me ayudaras, el problema es que tengo una celda con formato de fecha larga, en el cual necesito que si el dia fue sabado no tome ese dia en cuenta para una resta de fechas, el detalle es que cuando uso el si(a1=”sabado”,0, 1) busca que la selda solamente contenga la palabra sabado, como le puedo hacer para que el criterios sea que la celda A1 dentro de su texto contenga la palabra sabado.

    Gracias.

    Responder
    1. Moisés Ortíz Autor

      Hola Salvador, las fechas en Excel no son texto aunque tengan el formato de fecha larga por lo que no podrás utilizar la función SI con una condición de comparación con texto. Te recomiendo utilizar la función DIASEM la cual devolverá el día de la semana de cualquier fecha y que podrás utilizar como el criterio de la función SI, por ejemplo:
      =SI(DIASEM(A1) = 7, 0, 1)

      Responder
  43. OSCAR

    dentro de la funcion si existe alguna forma de que yo la condicione para que q el texto me salga en color; es decir tomemos un ejemplo basico si el valor es inferior a 50 que me apareca el numero en rojo, si esta entre 51 y 70 en color naranja y si es superior a 71 me aparezca en verde. ¿SE PUEDE?

    Responder
    1. Moisés Ortíz Autor

      Hola Oscar, la función SI no puede hacer eso, es necesario que utilices el formato condicional para modificar el color del texto. En el siguiente artículo encontrarás un ejemplo donde cambio el color de fondo de una celda, solo debes adecuarlo para cambiar el color de la fuente.:
      http://exceltotal.com/como-cambiar-el-color-de-una-celda-segun-valor/

      Responder
  44. erick poma

    hola gracias por la ayuda con la función SI de Excel. Me sirvió de mucho

    Responder
  45. moniza

    hola moises
    tengo una base de datos, en el cual son los estados de la republica que son 32 con sus municipios respectivamente,de los cuales necesito saber que municipios tienen entre 90,000 y 500,000 habitantes, y que aparezca el nombre del estado y que municipios en esos estados tienen esa condición. me podrias ayudar

    Responder
  46. Richard

    Hola Moises muy buenos aportes para mejorar el uso de esta herramienta que es EXCEL. tengo una consulta. es con respecto a fechas. tengo 3 columnas fecha recibido, fecha hoy, y dias por vencer. las celdas de dias por vencer les he dado formato condicional para que se pinten de 4 colores diferentes llegada las siguientes condiciones 1)>0 verde 2)>10 amarillo 3)>20 marron 4)>30 rojo (son fechas de vencimiento de diversos documentos el limite es 45). he intentado que la celda me arroje un mensaje cuando cumpla con las condiciones pero no lo he conseguido, le cree otra columna usando la función SI pero solo me da 2 mensajes diferentes. quisiera saber si puedo usar un mensaje por color de celda. Muchas gracias de antemano. y saludos.

    Responder
  47. jhon henry

    hola Sr Moises buen dia,
    Necesito conocer si con la funcion “SI” hay posibilidad de decirle a una celda que no calcule un valor si en esa celda se encuentra un valor negativo y que como resultado me de cero, o de lo contrario me calcule el valor…
    muchas gracias por su aporte

    Responder
    1. Moisés Ortíz Autor

      Hola Jhon, es posible hacerlo con la función SI. Por ejemplo, si el valor se encuentra en la celda A1 podrías utilizar la siguiente fórmula:
      =SI(A1<0,0,A1)

      Responder
  48. Alberto

    Hola.
    Que posibilidad hay que pueda comparar los valores de 2 celdas y la celda con un valor mas alto sea marcada en un color verde por ejemplo. Es posible?
    Puedo cambiar el color de texto o relleno de celda en una formula?

    Mil gracias.

    Responder
  49. Vanessa

    Hola Moises, como hago para que en mi columna de fechas de expedientes se cambie automáticamente a rojo las fechas que caducan
    gracias por tu tiempo

    Responder
  50. Nat

    Buenas noches, Moises te hago una consulta, tengo en una planilla de ingresos y egresos en las cuales distingo con lista si se paga con cheque o en efectivo, e ingreso datos del cheque, banco, valor, y número de cheque.
    Quiero lograr que automaticamente cuándo me paguen con cheque que complete en la hoja2 (la cuál tengo el listado de cheques, banco valor y número) Realicé esta fórmula==+IF(Mayo!D73=”cheque”;Mayo!E73), el inconveniente es que cuando me pagan en efectivo me aparece la palabra falso, lo cual me desordena la hoja2. Me gustaría que si el pago es en efectivo que deje todas esas celdas vacias, y que alli se copie en el momento que paguen con cheque… Es posible esto? Gracias por su ayuda!

    Responder
    1. Moisés Ortíz Autor

      Hola Nat, es posible hacer lo que necesitas con solo utilizar el tercer argumento de la función SI (IF) indicando una cadena vacía:
      =+IF(Mayo!D73=”cheque”;Mayo!E73;””)

      Responder
  51. Mariana

    Hola mi problema es que quiero que la funcion se fije si en una celda el resultado es mayor o menos que 0 y en ese caso ponga una “x”, por el contrario si esa celda no es ni mayor ni menos a cero es decir si es 0 quiero que se fije en otra celda lo mismo y si en los dos es cero que no escriba nada como se hace? Puse esta formula y no me funciona
    =SI(C5>0 o 0 o <0;"x";""))

    Responder
    1. Moisés Ortíz Autor

      Hola Mariana, te conviene evaluar el caso cuando la celda es igual a cero. Además, si la primera celda es igual a cero necesitas utilizar de nuevo la función SI para volver a evaluar la segunda celda lo cual implica utilizar la función SI anidada. Por ejemplo:
      =SI(C5=0,SI(D5=0,””,”x”),”x”)

      Responder
  52. Christian Bautista

    Hola moises, tengo un problema tengo esta formula que me funciona correctamente =SI(F2=1;DIA.LAB(G2;4);”0″) pero quiero que si en la celda F2 le diera un valor 4 (F2=4) me de el mismo resultado en la misma celda como hago esto he tratado mucho y no he podido??

    Responder
    1. Moisés Ortíz Autor

      Hola Christian, puedes utilizar la función O para permitir que la condición se cumpla cuando la celda sea igual a 1 o cuando sea igual a 4:
      =SI(O(F2=1;F2=4);DIA.LAB(G2;4);”0″)

      Responder
  53. EDGAR

    hola Moisés
    me podrías ayudar en una formula. tengo una celda en la cual necesito valorar si es positivo me multiplique por una determinada celda, pero si es negativo me lo multiplique por otra celda . me podrías apoyar

    Responder
    1. Moisés Ortíz Autor

      Hola Edgar, utiliza la función SI de la siguiente manera:
      =SI(A1>=0, A1*B1, A1*C1)

      Responder
  54. Oscar

    Gracias, estan muy interesantes sus comentarios sobre la formula!

    Responder
  55. Roberto Alvarez Mendoza

    Gracias Moises, con tus comentarios a las respuestas de los compañeros se me han aclarado algunas dudas al respecto, felicidades

    Responder
  56. Maria Amelia

    hola moises tengo informacion en dos hojas de exel, en el cual los campos son casi parecidos, a exepcion de un campo DNI, el cual son exactamnete iguales, quiero una funcion en la cual comparen los que son iguales.

    Responder
  57. SANDRA

    hola Moises, primero que todo, agradecerte el realizar esta pagina, no sabes cuanto me a ayudado, mi pregunta es la siguiente:
    en la celda h5 necesito poner una formula para que el resultado sea 0 ó 10 segun en la selda G5 sea SI ó NO

    Responder
    1. Moisés Ortíz Autor

      Hola Sandra, si los únicos valores posibles en la celda G5 son SI y NO, entonces puedes utilizar la siguiente fórmula:
      =SI(G5=”SI”, 10, 0)

      De lo contrario es necesario evaluar tanto el valor “SI” como el valor “NO” con la función SI anidada:
      =SI(G5=”SI”, 10, SI(G5=”NO”, 0))

      Responder
  58. Isabel

    Hola Moises,
    tengo el problema siguiente: saber el precio mensual, de los apartamentos sabiendo que”semi-amueblado” vale 5% mas que el precio de base, “amueblado” 20″ y “completo” 35% tengo esta, una de varias que he hecho pero me cuenta formar los argumentos, por favor me puedes ayudar.
    =SI(H6=F6;”Non Meublé”;SI(H6=F6+$L$10;”Complet”;SI(H6=F6+$L$8;”Semi-meublé”;SI(H6=F6+$L$9;”Meublé”))))

    Muchas gracias

    Isabella

    Responder
    1. Moisés Ortíz Autor

      Hola Isabel, no puedo ayudarte mucho porque desconozco lo que guardan las celdas H6, F6, L8, L9, L10, pero lo que sí te puedo decir es que tu fórmula solo regresa cadenas de texto: “”Non Meublé”, “”Complet”, etc.
      Si lo que necesitas es calcular el precio en base a la categoría del apartamento, entonces debes corregir tu fórmula para que regrese dicho cálculo. Suponiendo que la columna H tiene la categoría y la columna F tiene el precio base, entonces la fórmula sería algo como lo siguiente:
      =SI(H6=”Complet”; F6*1.35; SI(H6=”Meublé”; F6*1.20; SI(H6=”Semi-meublé”; F6*1.05)))

      Responder
  59. Rafael

    Una cuestión. Dentro de una función SI de excel me aparece este símbolo “” (parecen dobles guiones y no posee ningún argumento enmedio de ellos). Podeis ayudarme y decrime qué significan. Gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Rafael, son dobles comillas y en este caso representan una cadena de texto en vacía. Generalmente especificamos las cadenas de texto como: “uno”, “dos”, etc. pero cuando queremos que el valor de la celda quede en blanco utilizamos dos dobles comillas sin ningún carácter en medio de ellas.

      Responder
  60. Cindy

    Hola!! Buen día, solo con una pequeña consulta. No se como podría hacer para colocar por ejemplo yo quiero que me aparezca en una celda una imagen como resultado de una venta que alcanzo la meta propuesta. Acá dejo un ejemplo, solo que en vez de la palabra me gustaría que saliera la imagen por ejemplo de la estrella y los círculos, pero no se como poder hacerlo.
    =SI(B16>=28000;”EstrellaAmarilla”;SI(B16>=25000;”CirculoNegro”;”CirculoRojo”))

    De antemano muchas gracias!!

    Responder
  61. Alejandro Sisco

    Hola Moises, como haria para saber si un valor de una celda esta o no en un rango de valores ( 8<=X<=50), he tratado de usar la formula SI pero no me acepta un rango de valores me dice falso cuando es verdadero.

    Responder
    1. Moisés Ortíz Autor

      Hola Alejandro, puedes utilizar la función SI anidada o utilizar la función Y para asegurarte que se cumplan ambas condiciones. Por ejemplo:
      =Y(A1>=8, A1< =50)

      Te dejo un vínculo a un artículo donde encontrarás más información al respecto.
      http://exceltotal.com/condiciones-multiples-en-excel/

  62. Maili

    Hola Moisés soy nueva en esto pro mi pregunta es si se puede devolver un valor numérico con condición del falso y verdadero en ves del texto

    Responder
    1. Moisés Ortíz Autor

      Hola Maili, por supuesto que es posible, solo debes indicarlos en la fórmula. Por ejemplo, si al ser falso deseamos obtener el número cero y al ser verdadero deseamos obtener el número 1, la fórmula podría ser como la siguiente:
      =SI(A1>5, 1, 0)

      Responder
  63. Ana

    Buen día, Moises.

    Espero puedas ayudarme, quiero utilizar la formula “sí” (en Ingles) para una encuesta donde sí tiene la respuesta “1″ la celda permanezca igual, pero sí tiene la respuesta “2″ pasen a la celda A4 o que indique el numero “4″.

    Sacando algunas conclusiones en estas lecturas puse esta formula y me marca error.

    =IF(A1=1,”0″;IF(A1=2,”4″))

    Saludos.

    Responder
    1. Moisés Ortíz Autor

      Hola Ana, el error tal vez sea porque estás utilizando un punto y coma (;) después del segundo argumento del primer IF. Si tienes la configuración regional de E.E.U.U. debes utilizar coma (,) en lugar de punto y coma.
      Por otro lado, si quieres que la celda permanezca igual en caso de que sea igual a 1 entonces debes repetir la referencia de celda. Utiliza la siguiente fórmula:
      =IF(A1=1,A1,IF(A1=2,4))

      Responder
      1. NELSON

        BUENAS BUENOS DÌAS, SERA QUE ME PODES AYUDAR, CON UNA FORMULA PARA DARLE VALOR A UNAS PALABRAS, YO TENGO ESTA FORMULA =SI(H19>=1;”PRESENTE”;”DESCANSO”) Y LE QUIERO AGREGAR MAS COSAS, TAL COMO POR EJEMPLO AUTORIZADO, FRANCO, PARTE ENFERMO, NOSE SI ME PODES AYUDAR, DESDE YA MUCHAS GRACIAS.-

        Responder
  64. Gaby

    Hola Moisés, excelente artículo, la duda que tengo es la sigte; además de aprobado y reprobado quisiera que me salga que con el valor =0 me salga “abandono”, qué aumento?
    Gracias.

    Responder
    1. Moisés Ortíz Autor

      Hola Gaby, no me queda clara cual sería la condición para “ABANDONO” pero es casi seguro que lo solucionas con un SI anidado. Te dejo el vínculo a un artículo que habla al respecto:
      http://exceltotal.com/funcion-si-anidada/

      Responder
  65. German

    Buen dia Moises, a ver si me puedes ayudar

    Tengo en D7 la palabra Tarjeta, en E7 tengo $100
    En D8 la palabra Efectivo, en E8 tengo $100
    En D9 la palabra Tarjeta, en E9 tengo $100….

    La duda es: en E35 quiero sumar las cantidades que llevan la palabra Tarjeta. Se que se hace =suma(E7+E9+….etc), pero quiero ver si se puede que cuando ponga la palabra TARJETA “automaticamente” su puedan ir sumando en E35 las cantidades de la Columna E que llevan dicha palabra.

    Espero me haya dado a entender

    Gracias!!!!!

    Responder
  66. Lenny

    estoy tratando de realizar una formula donde si una persona tiene menos de 90 dias =0 pero si tiene de 90 a 180 lo multiplique por 6 y si tiene de 181 a 360 dias lo multiplique por 13 y de 360 en adelante por 21
    la puedo hacer individual, pero cuando trato de entrelazarla me da error
    ej. si(y(f4>90,f4181,f4<360)sueldo prom*13)

    Responder
    1. Moisés Ortíz Autor

      Hola Lenny, necesitas utilizar un SI anidado. Suponiendo que el valor se encuentra en A1, la fórmula que resuelve tu problema es la siguiente:
      =SI(A1<90,0,SI(A1<181, A1*6, SI(A1<361, A1*13, A1*21)))

      Responder
      1. Lenny

        Muchas Gracias, su opinión fue de gran ayuda.

        Responder
      2. iliana eth

        Con el comentario de Lenny he resuelto un problemita parecido al de ella lo traía en Excel 2010. Muy buena tu pagina Moisés. Gracias

        Responder
  67. SERRANA

    Hola Moises, tengo que modificar una lista de precios agregándole un 10%.
    Le aplico la función y por ejemplo: 90*1.1=99 o 160*1.1=176
    En ambos casos necesito que el resultado sea múltiplo de 5 (en el primer caso 100 y en el segundo 175) Se puede hacer una función que logre eso?
    Muchas gracias!!

    Responder
    1. Moisés Ortíz Autor

      Hola Serrana, puedes utilizar la función REDOND.MULT que hace el redondeo de un número al múltiplo deseado.
      REDOND.MULT(99,5) = 100
      REDOND.MULT(176,5) = 175

      Responder
  68. JuanI

    Hola Moisés, es primera vez que escribo, muy buena página.
    Te comento mi error es con la función “SI”, Estoy tratando de traer la descripción de una cta. contable, mi formula es la siguiente: =SI(C2=$E$2:$E$5;$F$2:$F$5;”F”), en conde C2 esta el n° de la cta. contable, en el rango E2:E5 esta la cuenta para la prueba lógica, en el rango F2:F5 tengo mi valor verdadero y finalmente F en caso de que sea falso. El problema es que si bien unas filas me las trae correctamente, otras me las trae con “F” y otras me da el siguiente error: #¡VALOR!, siendo que tengo todos los datos correctos.

    Muchas Gracias!!

    Responder
    1. Moisés Ortíz Autor

      Hola Juanl, el criterio que estás utilizando es incorrecto (C2=$E$2:$E$5;). No puedes comparar el valor de una celda con el de un rango a menos que vayas a utilizar fórmulas matriciales.
      Lo que debes hacer es crear la fórmula solo para la primera fila y posteriormente copiarla hacia abajo para obtener el resultado de cada fila. Me parece que por la lógica descrita deberías utilizar una fórmula como la siguiente:
      =SI(C2=E2; F2; “F”)

      Responder
  69. cecilia

    Hola Moises, tengo en la columna A muchos correos electrónicos, quiero que en la columna B, me aparezca exclusivamente los que terminen con @gmail.com; existe una fórmula para esta operación. Ya intente muchas y no me resulta.

    Responder
    1. Moisés Ortíz Autor

      Hola Cecilia, utiliza la siguiente fórmula:
      =SI(DERECHA(A1,10)=”@gmail.com”,A1,””)

      Responder
  70. MARGARITA

    Moisés, me encanta tu tutorial me ha servido bastante. Gracias

    Responder
  71. the miguel

    Te mando un saludo y te doy GRACIAS por la enseñanza de Excel que brindas; me fue de gran ayuda con un problema que tuve. Saludos de Lima-Peru.

    Responder
  72. Roberto Soler

    Buenos días Moisés. Te felicito por tu gran aporte a la enseñanza del Excel…

    Se me esta presentando un mensaje de falso en esta formula: =SI(M2>=25;SI(M2=1;SI(M2=31;SI(M2<=35;"2"))))
    Cuando M2 = 26 Perfecto. Cuando M2 = 5 Perfecto, o sea, los dos primeros argumentos.
    Pero cuando trato con cualquier valor entre 31 y 35, resulta FALSE
    No entiendo en que estoy equivocado y todavía me faltan 2 argumentos mas para completar la formula.
    Por favor si me podrías orientar en esta situación.
    De antemano muchas gracias.

    Responder
    1. Moisés Ortíz Autor

      Hola Roberto, discúlpame por lo que te voy a decir pero esta fórmula no hace mucho sentido. El segundo criterio SI(M2=1) jamás se cumplirá porque ya vienes de preguntar si el valor es mayor o igual a 25 y por lo tanto jamás será igual a 1. La última condición (M2< =35) solo se evalúa cuando M2 es igual a 31 por lo que siempre será verdadera.
      De hecho, ya que no tomas ninguna acción en toda la fórmula sino hasta que evalúas SI(M2<=35) podrías reemplazar toda la fórmula por lo siguiente (y seguirás teniendo el mismo resultado):
      =SI(M2>=25;SI(M2< =35;"2"))

      Te conviene leer un poco más sobre la función SI anidada y aquí te dejo un artículo que seguramente será de utilidad:
      http://exceltotal.com/tutorial-excel-2010-funcion-si-anidada/

      1. Roberto Soler

        Buenos días Moisés. Muchas gracias por tu gran ayuda. Efectivamente mi formula estaba mal escrita y gracias a tu lectura recomendada logre la correcta ejecución de la misma.
        Formula correcta:
        =SI(M3>=1;SI(M3=25;SI(M3=31;SI(M3=36;SI(M3=41;SI(M3=46;SI(M3=51;0)))))))))))))
        Nuevamente, muchas gracias por tus aporte…

        Roberto. Maracaibo – Venezuela

        Responder
  73. Julio

    Hola Moises, una felicitación por tu dedicación y animo para compartir conocimiento.
    Sabes, tengo un problema para encontrar la formula correcta a un argumento… la formula que elaboro para ejemplificar es la siguiente:
    =IF(A1=”CM*”,”CREDIT “,INVOICE”) la intención es pedir: Si A1 empieza texto con “CM” pon “CREDIT”, si nó, pon INVOICE.
    Este criterio lo puedo usar con la formula SUMIFS (para sumar criterios específicos), pero en este caso no quiero sumar solo quiero identificar. Podrás ayudarme?
    Te agradezco desde ya y espero atento a tu respuesta.
    Gracias!

    Responder
    1. Moisés Ortíz Autor

      Hola Julio, la función IF no acepta caracteres comodín (wildcard) en la prueba lógica. Tendrás que utilizar una función para hacer la comparación requerida, por ejemplo:
      =IF(LEFT(A1,2)=”CM”,”CREDIT”,”INVOICE”)

      Responder
      1. Julio

        Algo tan sencillo! y tan lógico!!! cómo es que ni siquiera intenté con esa!.
        Gracias Master! te visitaré mas seguido.

        Saludos!

        Responder
  74. Alvaro Cantos

    Saludos, Moises, tal vez me puedas ayudar, tengo que condicionar una celda, sumo (9+10+9+10) saco el promedio (9.5) si el resultado es igual o menor a (9) aumentar (hasta llegar a 10) que esta ubicado en otra celda, como una bonificacion y si es 10 no hacer nada.
    No se como aplicar la formula en excel

    atte.
    Alvaro Cantos

    Responder
    1. Moisés Ortíz Autor

      Hola Alvaro, utiliza la siguiente fórmula:
      =SI(PROMEDIO(9,10,9,10) <= 9, 10)

      Responder
  75. ANTONIO

    MOISES QUIERO SABER SOBRE LA FORMULA QUE ME TIRE QUE LA LETRA B ES CREDITO Y LA LETRA A CONTADO
    PERO NO COMO HACERLA CON LA CONDICION SI ME PUEDES AYUDAR

    Responder
    1. Moises Ortiz Autor

      Hola Antonio, para eso necesitas un SI anidado:
      =SI(A1=”A”, “CONTADO”, SI(A1=”B”, “CREDITO”))

      Te dejo un artículo con más información sobre la función SI anidada:
      http://exceltotal.com/funcion-si-anidada/

      Responder
  76. Omar

    Hola Moises tengo un problema con una formula, estoy trabajando en una base de datos y quiero agrupar por rangos de edad casos presentados, puse esta formula pero me marca error, =SI(E226=21=26=31=41=51=61<=70,"61 a 70 años"))))))), el resultado que quiero es que si tengo casos con edades de 18, 19 y 20 años me ponga el texto, hasta 20 años y asi sucesivamente

    Responder
  77. Byron Chali

    Buenos dias Moises.
    Espero puedas ayudarme con la siguinte duda. Estoy tratando de hacer un calculo promedio de combustible dependiendo de el destino indicado.
    Tengo una columna de destinos y una columna de combustible en galones.
    Los destinos pueden ser varios, estos estan por zonas 1, 2, 3, o Lugares especificos.
    Lo que necesito es que cuando ingrese en una celda un destino pueda darme el consumo de combustible , pero no consigo hacerlo.
    esta es la formula que tengo:
    =SI(P4=$C$4:$C$42,$K$4:$K$42,”ingrese cantidad”)
    solo me devuelve el valor del destino 2, no funciona con otro destino pues me imprime “ingrese cantidad”
    Gracias por la ayuda.
    Saludos.

    Responder
    1. Moisés Ortíz Autor

      Hola Byron, el criterio P4=$C$4:$C$42 es incorrecto (a menos que sepas utilizar fórmulas matriciales).
      Haz la comparación sólo de una fila y después copia la fórmula hacia abajo para obtener el resultado de las demás. Si el valor a comparar es siempre el de la celda P4, entonces la fórmula debería ser la siguiente:
      =SI(C4=$P$4,K4,”ingrese cantidad”)

      Al copiarla hacia abajo la referencia de C4 se cambiará automáticamente por C5 y K4 por K5.

      Responder
  78. Andrea

    Hola que tal, solo queria agradecer por tu ayuda, en verdad nos sirve de mucho.. yo estoy llevando el curso de excel 1 pues habia un problema que no podia resolver y me alegro haber encontrado la solucion por medio de esta pag.web Muchas Gracias :) , se que volvere pronto

    Responder
  79. Catalina

    Hola Moises,
    quiero evaluar varias condiciones y según el cumplimiento de ellas generar un texto. Usé la función SI con la función Y pero no se deja anidar, es decir, sólo evalúa la primera condición lógica y si no se cumple sale FALSO no evalúa el resto de condiciones. Así fue como lo realicé: =SI(Y(F5=0,H5=100%),”Satisfactorio”, SI(Y(0<F5<=15, 0%<=H5<70%),"Alerta",SI(Y(0<F5<=15, 70%<=H5<100%),"A Tiempo")))
    Cómo se hace correctamente???

    Gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Catalina, la función Y devolverá FALSO con que una sola condición sea falsa. Para que la función Y devuelva VERDADERO todas las condiciones deben ser verdaderas. Si quieres el comportamiento opuesto debes utilizar la función O. Consulta el siguiente artículo para conocer más de estas dos funciones:
      http://exceltotal.com/condiciones-multiples-en-excel/

      Responder
  80. Ernesto Vasquez

    QUE TAL MOISES QUISIERA SABER SI DENDTRO DE LA CONDICION SI SE PUEDEN COLOCAR MAS DE UNA PRUEBA LOGICA EN LA MISMA CONDICION Y SI SI SE PUEDE COMO SEPARA CADA PRUEBA LOGICA??

    Responder
  81. raul

    Moises

    Copie esta formula para comparar el contenido de 3 columnas , si son giuales deberia darme ok, si soon distintas 0, pero no me funciono
    SI( (M11=N11=O11),”OK”,”0″)

    Responder
    1. Moisés Ortíz Autor

      Hola Raul, es inválido el criterio que estás intentando utilizar: M11=N11=O11. Debes utilizar la función Y para hacer las comparaciones entre las celdas:
      =SI(Y(M11=N11,M11=O11,N11=O11),”OK”,0)

      Responder
  82. Gabriela Lázarol

    Muy buenas tardes Móises, tengo una duda en una columna tengo fechas de contestación de un cuestionario y quiero que al final me devuelva el total de cuestionarios contestados, ¿es posible que con la función SI me devuelva el total de las celdas que tienen fecha y las que quedan en blanco?, espero me ayudes con esta duda

    Responder
  83. Indira

    Hola Moises:
    Consulta como puedo hacer para que la celda que me sale hacer pedido tambien se coloque automaticamente en color rojo.

    Responder
  84. Eliana Zambrano

    gracias por tu página, solo con tus ejemplos pude realizar rápidamente la tarea que debía hacer.

    Responder
  85. Karen

    Buenas moisés,
    En primer lugar darte mi enhorabuena porque he estado buscando información y ayuda en otras páginas y la tuya me ha resultado la mejor.
    Necesitaría un cable para determinar la fórmula que combina función condicional con números.
    De esta manera yo creé la fórmula =SI(2>=E3>=8, “2″, SI(9>=E3>=15, “3″)) pero me da fallo.
    Esta fórmula interpretaría que si los valores a rellenar en las celdas donde está definida la función son iguales o mayores que dos pero iguales o menores que 8, ésta celda debería reportar el valor numérico 2 (éstos valores se encuentran en otra columna que he creado) a continuación si el valor de la columna es mayor o igual a 9 o menor e igual a 15 esta columna debería de reportar el valor 3.
    Espero haber explicado bien mi caso.

    Responder
  86. Juan Carlos

    Hola tengo la siguiente pregunta : estoy creando un archivo el cual llevan varios datos fecha ,direccion, nombre etc lo que quisiera saber es si escribo un nombre en la D4 y luego lo vuelvo a escribir en la D85 me puede aparecer un texto que diga que ya existe, gracias por tu ayuda.

    Responder
  87. marggie

    excelente articulo, bien hecho!!!

    Responder
  88. Pedro

    Buenas tardes, tengo una duda. Como programaría en una celda, que el producto obtenido en una celda si es NEGATIVO ES XU, y si es positivo es igual a XL.

    Responder
    1. Moisés Ortíz Autor

      Hola Pedro, utiliza la siguiente fórmula:
      =SI(A1<0,”XU”,”XL”)

      Responder
  89. ERICK

    Saludos, estoy haciendo una lista para obtener calificaciones y quisiera saber si puedo hacer que en el promedio arroje la calificación mínima de 5 cuando este es menor

    De antemano gracias

    Responder
    1. Moisés Ortíz Autor

      Hola Erick, tendrás que usar una fórmula como la siguiente:
      =SI(PROMEDIO(A1:A10) < 5, 5, PROMEDIO(A1:A10))

      Responder
  90. Marcosir

    Hola Moisés, muchas gracias por toda la ayuda que entregas, tengo un problema con la formula SI, asociada a fechas, lo que necesito es que que entre el 01/07/2013 y 31/07/2013 me arroje en la celda “Julio”, entre el 01/08 y 31/08 “Agosto” , así sucesivamente.

    De antemano agradezco tu ayuda.

    Saludos

    Responder
  91. Alejandra

    Hola!

    Como estas? Esta muy buena tu pagina!, Estoy haciendo un formato para presupuesto, y digamos en una hoja tengo el catalogo de material con precios, y quiero que en la hoja de presupuesto no se puedan utilizar otros material mas que los que vienen en el catalogo, para esto, puse una lista despegable para elegirlos y me gustaría que al elegir un material en automático se actualice la celda donde esta el costo, eso se podría hacer?

    Te agradezco mucho de antemano!!!

    Saludos!!

    Responder
  92. GALEON

    Tengo dos filas una con fechas y otra con números.
    Quiero comparar en cada fila si la celda de la fecha es igual o menor al dia de hoy, entonces que vaya sumando el valor de la celda de la derecha.
    Cómo se hace ?

    Responder
    1. Moisés Ortíz Autor

      Hola Galeon, te recomiendo utilizar la función SUMAR.SI. Si las fechas están en la columna B y los números en la columna A, podrías usar una fórmula como la siguiente:
      =SUMAR.SI(B1:B99,”< =" & HOY(), A1:A99)

      Para más información sobre la función SUMAR.SI consulta el siguiente artículo:
      http://exceltotal.com/la-funcion-sumar-si-en-excel/

  93. Susana Manqueros

    Hola Moisés, no se si la formula de SI me ayude en lo que necesito.
    Para hacer un reporte de nomina necesito:
    si en el rango de la celda B3 a B10 existe una R(de retardo), que me aparezca una N(de que no se gana el bono)y que si no existe ninguna R, poner una S(de que si se gana el bono).
    Si la formula SI no es lo que necesito, podrías indicarme como le puedo hacer por favor?

    Responder
    1. Moisés Ortíz Autor

      Hola Susana, lo mejor será utilizar la función CONTAR.SI junto con la función SI.
      =SI(CONTAR.SI(B3:B10,”R”)>0, “N”, “S”)

      La función CONTAR.SI devolverá las cuenta de letras “R” dentro del rango B3:B10 y en caso de ser mayor a 0, la función SI devolverá una letra “N”, de lo contrario devolverá una letra “S”.
      Para aprender más del a función CONTAR.SI consulta el siguiente artículo:
      http://exceltotal.com/la-funcion-contar-si-en-excel/

      Responder
  94. José Alvarez

    Estimado
    Estoy intentando pedirle a la hoja de cálculo lo siguiente:
    Quiero que de un valor de celda por ejemplo 50 pueda decidir entre si es alto, medio y bajo, sin embargo solo se hacer entre dos desiciones ya sea alto o bajo, y quiero pedir su ayuda para poder introducir otra desición como medio.
    Me puede ayudar al respecto.
    Gracias

    Jose Alvarez

    Responder
  95. oswaldo amara

    Buenas tardes moises, tengo el siguiente problema: estoy usando excel para elaborar ordenes de pago en donde se especifica: Tipo de Pago (M.O., Materiales, Fletes, Administrativos), N° de Cheque, Beneficiario, C.I. o Rif y Monto, al final de la orden necesito sumar el total de cada tipo de pago: Total M.O. XXXXX, Total Materiales XXXXX, Total Fletes XXXXX, Total Administrativos XXXXX, cabe destacar que las ordenes son mixtas y pueden haber hasta 15 cheques por cada tipo de pago. Como puedo hacer en ese caso

    Responder
  96. Susana Manqueros

    Hola Moisés
    Disculpa si en la func CONTAR.SI necesito 2 criterios, como le hago?

    Responder
  97. Laura B

    Buenos dias Moisés,
    Llevo varios dás dandole vueltas a una funcion SI que me esta dando muchos problemas, esperaba que pudieras ayudarme ya que me condiciona el buen funcionamiento de todo el libro de cálculo.
    Tengo dos hojas en el mismo libro, con el mismo formato, es una cuadro de datos de las mismas dimensiones en ambas.
    En una de las hojas el cuadro tiene datos y en la otra el cuadro tiene P1, P2, P3 P4 P5 P6 de forma aleatoria de manera que en una misma fila puede existir cualquier combinacion de P1 a P6
    El caso es que quiero que cruce informacion entre ambas hojas. De forma que sume por filas aquellos datos de la hoja 1 en los que exista P1, P2, P3 P4 P5 o P6 en la hoja 2. Sumando solo los de P1, o solo los de P2 pero no todos.
    En los totales de la hoja 1 de P1 estoy escribiendo esto:
    =SI(‘Hoja 2′!$C9:$Z9=P1;SUMA($C9:$Z9);0)
    =SI(‘Hoja 2′!$C10:$Z10=P1;SUMA($C10:$Z10);0)

    Si puedieras ayudarme te estaria muy agradecida. Un saludo.
    Laura

    Responder
    1. Moisés Ortíz Autor

      Hola Laura, la fórmula que has colocado es una fórmula matricial. ¿Sabes como utilizar ese tipo de fórmulas?
      Espero que sí, porque la solución que te sugiero es utilizar una fórmula matricial:
      =SUMA((‘Hoja 2′!C9:Z9=”P1″) * C9:Z9)

      Recuerda pulsar Ctrl + Mayús + Entrar para introducir esta fórmula. Si quieres saber más sobre cómo sumar con varias condiciones, lee el siguiente artículo:
      http://exceltotal.com/sumar-y-contar-con-varias-condiciones-en-excel/

      Responder
  98. Herrmann

    Estimado Moises, mi nombre es Herrmann y te escribo dedsde AZ en US, sucede que no doy que funcion utilizar para una hoja de calculo. Te cuento. En la columna A pongo el nombre, en la B debe decir YES o NO, después tenemos pares de columnas la CD la EF, GH IJ, KL, MN, OP, etc… la primera columna lleva una x y la segunda un codigo…..pero se da el caso que un codigo digamos en KL, en este caso L dira 600 y en K habra una X, pero ese significa NO en mi columna B…..
    La Funcion la pondre en B y en palabras debe decir…. Aquí dira YES si en la columna W:W hay una X, aqui dira que NO si en la columna K:K hay una X, y asi lo mismo para diez columnas…..

    Responder
    1. Moisés Ortíz Autor

      Hola Herrmann, me está costado un poco de trabajo comprender el problema que tienes. No me queda muy claro si cuando dices “columna W:W” te refieres a la totalidad de la columna W, pero supongo que si debido a la nomenclatura que estás utilizando. En ese caso la fórmula que podrías utilizar es la siguiente:
      =IF(COUNTIF(W:W,”X”)>0, “YES”, IF(COUNTIF(K:K, “X”)>0, “NO”, “”))

      La función COUNTIF se encargará de contar todas las apariciones de X en la columna W y en caso de que aparezca al menos una vez, la función IF colocará la palabra “YES”. En caso de que esta primera condición no se cumpla, entonces se revisa la columna K y en caso de encontrar una X se coloca la palabra “NO”. He escrito las funciones en inglés porque supongo que tienes una versión de Excel en inglés, pero si no es así, la equivalencia de funciones es la siguiente:
      COUNTIF = CONTAR.SI
      IF = SI

      Responder
  99. Michelle Vargas Perez

    Saludos:
    Estoy creando un registro de notas académicas. Tengo ya el promedio en la clase de cada estudiante, pero necesito crear una formula para determinar la nota en otra columna. La curva estandar es la siguiente:
    Promedio: 100 a 90 = A
    89 a 80 = B
    79 a 70 = C
    69 a 60 = D
    59 a 0 = F
    Cómo sería la fórmula que tengo que utilizar??
    Gracias anticipadas

    Responder
  100. Angelica

    Tengo una hoja en excel que contiene el numero de cliente y el nombre del cliente en una misma fila.
    En otra hoja quiero que cuando yo ponga el numero de cliente en la columna A me aparezca en el mismo renglón pero en la columna D el nombre del cliente.
    Se puede usar con la funcion “SI”

    Responder
  101. Ronald Rodriguez

    Buenas tardes Moisés, te he escrito anteriormente pero no he tenido la suerte de obtener tu ayuda.
    Mi problema es para un formato de pedidos y no he logrado resolverlo. Necesito que la formula me de un numero entero y positivo. Yo construí la siguiente formula pero en algunos casos me da números negativos por ende me falta esa condición, que en caso de resultar negativo me redondee a Cero (0).
    SI(Y((((E41-F41)/10)>0),(((E41-F41)/10)<1)),1,((E41-F41)/10))
    Estaré muy agradecido.

    Responder
    1. Moisés Ortíz Autor

      Hola Ronald, ya que necesitas evaluar 2 posibles resultados de ((E41-F41)/10) será necesario utilizar un SI anidado. Por simplicidad de la fórmula he sustituido ((E41-F41)/10) por X1:
      =SI(Y(X1>0,X1<1), 1, SI(X1<0, 0, X1))

      Consulta el siguiente artículo para saber más sobre la función SI anidada:
      http://exceltotal.com/tutorial-excel-2010-funcion-si-anidada/

      Responder
  102. Nelson Celis Quintana

    Moisés Buenos días…
    Estoy elaborando un simulador para mi estudiantes donde ellos practicaran la función Si.
    Para cada Opción he asignado una celda. Por Ejemplo: Una Celda para la celda a evaluar, enseguida para el Operador Relacional y así sucesivamente.
    Lo que estoy buscando es que al terminar de digitar todas las opciones la Hoja de Calculo le indique al estudiante si esta Bien o debe Revisar lo que digito.
    Tengo el siguiente Problema: Como sabemos los textos dentro de la función van entre Comillas, A la hora de validar los texto en comillas me saca error.
    Yo escribo en la celda el texto entre comillas Ejemplo “Excelente”. Como hago para que la función me Valide esa información entre comillas.
    Le Agradezco y le deseo EXITOS.
    NELSON CELIS QUINTANA

    Responder
    1. Moisés Ortíz Autor

      Hola Nelson, la única manera de crear un simulador efectivo es utilizando VBA para validar el tipo de dato y formato correcto de cada uno de los argumentos de una función de Excel. No me queda claro si esa es la manera en que lo estás haciendo.

      Responder
  103. Eduardo

    Quiero por favor saber si hay alguna opcion que me permita pintar una celda de color rojo por ejemplo, si el contenido de otra celda es mayor que cero.
    La idea es de pintar de rojo la celda donde esta el nombre de un cliente y en la celda de egresos ha habido un pago

    Responder
  104. Ana María

    Estoy haciendo un plan de cuentas, en la hoja tengo clasificadas las cotizaciones realizadas por A (Aprobada), E (En espera), L (Perdida), quiero que en una casilla me salga la suma de las cotizaciones aprobadas, en otra la suma en espera, y por último en una la suma de las cotizaciones perdidas. Es posible hacerlo con esta fórmula?

    Responder
  105. Josh G

    Hola Moises lamento molestarte pero veo que das bastante atencion a las preguntas que te hacen, pues mi consulta es como puedo evaluar dos celdas al mismmo tiempo es decir algo asi:
    =if(c8,c9=0 etc, etc,
    lo que necesito es q en caso de que las dos esten en cero la formula haga algo pero con solo una celda que cambie de valor haga otra, he probado tambien asi:
    =if (c8+c9=0
    pero no me funciona. si puedes ayudarme te lo agradezco.

    Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>