Comparar valores en Excel

Para poder comparar valores en Excel debemos hacer uso de los operadores de comparación. A través de estos operadores podremos saber si un valor es mayor, igual o diferente al valor con el cual lo estamos comparando.

Al utilizar los operadores de comparación recibiremos como respuesta un valor VERDADERO o un valor FALSO de acuerdo a como se haya evaluado la expresión.

El operador Igual a (=)

Para comparar dos valores y saber si son iguales podemos utilizar el operador Igual a (=). Observa el siguiente ejemplo:

Comparar valores en Excel

La columna C contiene las expresiones de comparación entre los valores de la columna A y la columna B. Observa cómo para la celda C2 el resultado es FALSO por que los valores comparados son diferentes. En la imagen superior he colocado unos paréntesis alrededor de la comparación de manera que podamos diferenciar el operador Igual a (=) del signo igual que identifica el inicio de la fórmula. Sin embargo podemos quitar los paréntesis y la fórmula funcionará correctamente.

El operador Mayor que (>)

El operador Mayor que (>) nos permite saber si un valor es mayor que otro. Observa cómo funciona este operador en los datos de ejemplo:

Comparar dos valores en Excel

Podemos también juntar este operador con el signo de igual de manera que tengamos  una comparación Mayor que o igual a (>=) la cual podremos utilizar para comparar valores. Observa la diferencia en los resultados al utilizar este operador:

Cómo comparar valores de dos columnas en Excel

El operador Menor que (<)

El operador Menor que (<) verifica que el valor de la izquierda de la expresión sea menor que el valor de la derecha.

Ejemplo comparar valores en Excel

De la misma manera podemos unir el operador menor que con el signo igual para tener una comparación Menor que o igual a (<=). Observa los resultados:

Cómo comparar celdas en Excel

El operador Diferente de (<>)

El último operador de comparación es el operador Diferente de (<>). Este operador nos ayuda a saber si los valores comparados son diferentes,  en cuyo caso obtendremos un valor VERDADERO.

Comparar el contenido de celdas en Excel

Si los valores son iguales entre sí, entonces el operador nos regresará un valor FALSO como es el caso de la celda C4 del ejemplo. Es importante familiarizarse con los operadores de comparación porque serán de gran utilidad al momento de trabajar con otras funciones de Excel.

Artículos relacionados
Precedencia de operadores aritméticos

18 pensamientos en “Comparar valores en Excel

  1. Julio Garcia

    Sus artículos son todos muy comprensibles.

  2. Roberto Correa

    Estimado Moisés Ortíz, quiero felicitarte por tu forma de explicar todos los contenidos de Excel que para muchos no es nada sencillo. Estoy viendo y repasando mis conocimientos con todo el material que dispones en este sitio. Muchas Gracias por compartir todo esto con nosotros. Sigue así.
    Muy agradecido.
    Roberto Correa.
    Artigas/URUGUAY

  3. Emanuel

    SON UNOS GENIOS, ME SALVARON EL PARCIAL DE INFORMÁTICA

  4. manuelroberto

    De gran ayuda para los que se estan iniciando en formulas y funciones en excel. Muy clara y didactica la explicacion.

  5. JGMel

    Estoy aprendiendo mucho de Excel gracias a estos tutoriales

  6. Diego

    Hola Moises, excelente pagina. Una duda. Tengo una columna de Costos. Y en funcion a estos costos necesito saber el precio. Mis costos van desde algunos articulos de $10 a otros de $800.
    Por ejemplo. Si es entre $10 y $20, ganar $6. SI los costos dan entre $600 y $770 ganar $170.
    Como lo hago? Muchas gracias. Diego.

    1. Moisés Ortíz Autor

      Hola Diego, debes utilizar la función SI anidada para evaluar varios casos y por otro lado utilizar la función Y para evaluar múltiples criterios. Para el ejemplo que das, la fórmula a utilizar sería la siguiente:
      =SI(Y(A1>=10,A1< =20), 6, SI(Y(A1>=600, A1<=700), 170))

      1. John

        Moises Ortiz, buen dato ………gracias

  7. Toledo J.

    Gracias, en mi nuevo empleo requero de usar constantemente formulas, y aunque estaba y familiarizado, me es muy util aprender y repasar, que buenos articulos .. gracias

  8. Rousse

    Es muy completo todo lo que nos explicas de Excel. Me viene genial la teoría con sus ejemplos.
    Gracias.

  9. ADRIANA

    hola..mi problema es el siguiente necesito comparar en dos columnas de datos de pacientes de diferentes años, con numero diferentes números de cédula de identidad, teniendo una de las columnas una cantidad superior a la otra.. la primera es de 1196 filas y la segunda 39 únicamente.. yo necesito saber cuales son los números de cédula que coinciden una de la otra.. gracias

  10. duibell

    brother como le hago para hacer lo siguiente espero que me apoyes porque ya lo he consultado con “masters” del excel y nada mas no dan. lo qu quiero es por decir un ejemplo es que determinado valor si es mayor a 5 y menor a 10 multiplicarlo por 5, y si es mayor a 10 y menor a 15 multiplicarlo por 10.
    espero puedas apoyarme con la formula para ese problema

    1. Moisés Ortíz Autor

      Hola Duibell, utiliza la siguiente fórmula:
      =SI(Y(A1>5, A1< =10), A1*5, SI(Y(A1>10, A1<=15), A1*10, A1))

  11. autentico

    Excelente pagina !!!

  12. Eliseo Camacho

    Buen dia, espero me puedan responder esta duda, si tengo tres valores por ejemplo 3,1,2 y quiero con una formula acomodar en tres celdas, mayor, medio y menor respectivamente, como le hago, gracias

    1. Moisés Ortíz Autor

      Hola Eliseo, para obtener el mayor utiliza la función MAX, para obtener el menor utiliza la función MIN. El problema será cómo obtener el valor de en medio porque no existe una función tal que discrimine valores para obtener un tercero. La única opción que veo posible por ahora es crear tu propia función VBA.

  13. JULIO CESAR LOPEZ

    REALMENTE ES EXCELENTE TU APORTE- CUANTA AYUDA ¡ME SATISFACE SABER CUANTO HE APRENDIDO- ES ATRAPANTE EXCEL Y MAS CUANDO SE CUENTA CON UN GRAN METODO DE ENSEÑANZA COMO ES EL TUYO,.
    GRACIAS.-
    RIVERA- URUGUAY