Calcular el promedio ponderado en Excel

Para calcular el promedio ponderado en Excel podemos utilizar varios métodos, uno de ellos es utilizar funciones matriciales. Otro método que funciona perfectamente es utilizar la función SUMAPRODUCTO.

Definición de promedio ponderado

Antes de continuar déjame dar una definición de promedio ponderado. Todos sabemos que un promedio se obtiene de sumar todos los valores y dividirlos entre el número total de valores. La diferencia con un promedio ponderado es que a cada valor se le asignará una ponderación y por lo tanto algunos valores influirán más en el resultado que otros.

Ejemplo de promedio ponderado

Para dejar claro este concepto hagamos el siguiente ejemplo. La empresa Financiera Excel S.A. ha vendido 10,000 acciones en un solo día. Se vendieron 4000 acciones a un precio de $575, 3500 acciones a un precio de $585,  2000 acciones a $595 y 500 acciones a un precio de $600. ¿Cuál es el precio promedio ponderado de las 10,000 acciones?

Lo primero que debemos hacer es determinar el peso relativo de cada lote de acciones, lo cual es muy fácil de obtener con tan solo dividir la cantidad de acciones de cada lote entre el total de acciones. En el siguiente ejemplo ya he dado formato de porcentaje a dicha división:

Calcular el promedio ponderado en Excel

Para obtener el precio promedio ponderado de las acciones debemos multiplicar el precio de cada lote por su ponderación y sumar los resultados.

Promedio ponderado en Excel 2010

En lugar de hacer cuatro operaciones de multiplicación (D2:D5) y una suma (D6) te mostraré cómo hacer el mismo cálculo en una sola fórmula.

Promedio ponderado con funciones matriciales

Un método para calcular el promedio ponderado en Excel es utilizar funciones matriciales. Para hacerlo debemos utilizar la siguiente fórmula:

=SUMA(B2:B5*C2:C5)

La única condición es que, en lugar de pulsar la tecla Entrar para ingresar esta fórmula, debemos mantener apretadas las teclas CTRL + MAYÚS y entonces pulsar la tecla Entrar. El resultado que obtenemos es el siguiente:

Promedio ponderado en Excel con funciones matriciales

Promedio ponderado con la función SUMAPRODUCTO

El segundo método que podemos utilizar para calcular el promedio ponderado en Excel es la función SUMAPRODUCTO. Esta función toma como argumentos los dos rangos que serán multiplicados y posteriormente sumados:

=SUMAPRODUCTO(B2:B5,C2:C5)

Observa cómo el resultado que obtenemos con la función SUMAPRODUCTO es el mismo que en los dos casos anteriores.

Promedio ponderado en Excel con la función SUMAPRODUCTO

Ahora ya conoces diferentes métodos para calcular el promedio ponderado en Excel.

12 pensamientos en “Calcular el promedio ponderado en Excel

  1. Miguel Castillo

    solo para aclarar la tecla es Ctrl + Mayus, si no da el resultado entonces Ctrl+Shift, en la actualidad muchos teclados la tecla mayus es la tecla shift, espero haberme explicado saludos

    1. Moises Autor

      Hola Miguel. Gracias por tu comentario. La tecla Mayus es lo mismo que la tecla Shift en todos los teclados. En español acostumbramos llamarle tecla Mayus pero también es conocida como la tecla Shift por su nombre en inglés (Shift key).

  2. ana

    excelente explicacion sobre el promedio ponderado en Excel. Muchas gracias.

  3. Renato Olivares

    Gua cada día aprendo mucho mas cosas, es increible que uno utiliza los metodos mas dificil, habiendo caminos mucho más cortos, gracias!

  4. aldo

    Muy buena explicación. Gracias.

  5. carlos

    Me fue útil tu explicación. SALUDOS!!

  6. Luis Fonseca Ruiz

    Muy bueno los ejemplos y mejor con la ayuda de excel
    Gracias

    1. santiago meza barreto

      exelentes ejemplos cada día trato de aprender un poco mas gracias estuy muy agradecido

  7. Darwin PC

    Muy buena explicación, muy bien detallada. Será posible que corrijas el siguiente error, luego de la segunda figura:
    …cuatro operaciones de multiplicación (D2:25) y…..
    donde lo correcto sería (D2:D5) porque ese numero 25 confunde

    1. Moisés Ortíz Autor

      Hola Darwin, gracias por tu observación y comentario, ya hice la corrección.

  8. Henk

    Estimado millon de gracias por la explicación y el tiempo que te tomastes para ayudar en la web.

  9. CARLOS

    Gracias.. me fue muy útil.